<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="keywords" content="News, government,Election 2016, new richmond, wisconsin, scottie ard, Rob Stafsholt, 29th district" />
<meta property="news_keywords" content="News, government,Election 2016, new richmond, wisconsin, scottie ard, Rob Stafsholt, 29th district" />
<meta property="author" content="Raymond Rivard" />
<meta property="description" content="The New Richmond VFW Post 10818 Auxiliary hosted a candidate forum at the civic center in New Richmond Thursday, Oct. 13.The live-streamed event that features..." />
<meta property="twitter:image" content="http://www.newrichmond-news.com/sites/default/files/styles/16x9_430/public/field/image/IMG_9817.JPG?itok=g5ISaUFW" />
<meta property="twitter:site" content="newrichmondnews" />
<meta property="og:description" content="The New Richmond VFW Post 10818 Auxiliary hosted a candidate forum at the civic center in New Richmond Thursday, Oct. 13.The live-streamed event that features the debate between Republican Rob Stafsholt and Democrat Scottie Ard, the two candidates vying for the 29th Assembly District seat, is included..." />
<meta property="article:author" content="https://www.facebook.com/newrichmondnews/?ref=hl" />
<meta property="twitter:description" content="The New Richmond VFW Post 10818 Auxiliary hosted a candidate forum at the civic center in New Richmond Thursday, Oct. 13.The live-streamed event that features the debate between Republican Rob Stafsholt and Democrat Scottie Ard, the two candidates vying for the 29th Assembly District seat, is included..." />
<meta property="image:alt" content="Rob Stafsholt and Scottie Ard at Thursday night&#039;s debate in New Richmond. (Raymond T. Rivard photograph)" />
<meta property="article:tag" content="News, government,Election 2016, new richmond, wisconsin, scottie ard, Rob Stafsholt, 29th district" />
<meta property="article:publisher" content="https://www.facebook.com/newrichmondnews" />
<meta property="article:published_time" content="2016-10-14T12:32:52-05:00" />
<meta property="article:modified_time" content="2016-10-14T12:32:52-05:00" />
<meta property="twitter:url" content="http://www.newrichmond-news.com/news/government/4136408-watch-29th-district-state-assembly-candidate-forum" />
<meta property="og:site_name" content="New Richmond News" />
<meta property="og:image:height" content="300" />
<meta property="twitter:title" content="WATCH: 29th District State Assembly candidate forum" />
<meta property="og:image" content="http://www.newrichmond-news.com/sites/default/files/styles/square_300/public/field/image/IMG_9817.JPG?itok=kbP5S5dn" />
<meta property="og:title" content="WATCH: 29th District State Assembly candidate forum" />
<meta property="og:image:width" content="300" />
<meta property="og:type" content="article" />
<meta property="fb:app_id" content="274677719346518" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="og:url" content="http://www.newrichmond-news.com/news/government/4136408-watch-29th-district-state-assembly-candidate-forum" />
<link rel="shortcut icon" href="http://www.newrichmond-news.com/sites/all/themes/newrichmondnews_theme/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="http://www.newrichmond-news.com/sites/all/themes/newrichmondnews_theme/images/touch-icon.png" type="image/png" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, minimum-scale=1, user-scalable=no" />
<link rel="amphtml" href="http://www.newrichmond-news.com/news/government/4136408-watch-29th-district-state-assembly-candidate-forum?amp" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="shortlink" href="/node/4136408" />
<link rel="canonical" href="/news/government/4136408-watch-29th-district-state-assembly-candidate-forum" />
    <title>WATCH: 29th District State Assembly candidate forum | New Richmond News</title>
    <link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_n1pCl2MA43tzliKvK4qXdpArepfCRU6u4sc5BywLwKU.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/all/themes/fcc_basetheme/css/article-slider.css?of02v8" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?of02v8" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/all/themes/newrichmondnews_theme/css/global-no-mqs.css?of02v8" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/all/themes/newrichmondnews_theme/css/global.css?of02v8" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_Bj-jFqaBjX6v88CkQD1JMwiNdFSI1lqdTZ1bxB6EF28.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.newrichmond-news.com/sites/default/files/css/css_MvOCAwQOqoNweN9GvZQn0wOkQS5L_dM3uVx3GJ3vCQo.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_OKeCwkv74_Arj-XTFvk5raD5ho-wMA6Yziy9sT28j2U.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_AqQx_MnxyTtG4vVUDQR_AFWbgg12UAytrjhpbW8bOSA.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-17', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var site_latitude = 45.12302; var site_longitude = -92.5365865;
//--><!]]>
</script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_deAPLjZEFhzHOQio0Oh8FHOfZv41QAYVZ3or6AjCey0.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/modules/custom/fcc_weather/scripts/min/fcc_weather_map_control.min.js?of02v8"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?of02v8"></script>
<script type="text/javascript" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?of02v8"></script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-NewRichmondNews"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        var ybotq = ybotq || [];
        (function() {
        var js = document.createElement('script');
        js.src = '//cdn.yldbt.com/js/yieldbot.intent.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(js, node);
        })();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

        function ybWidth(){
          var w = window,
              d = document,
              e = d.documentElement,
              x = Math.max(e.scrollWidth,e.offsetWidth,e.clientWidth);
          return x;
        }
        ybotq.push(function () {
          if(ybWidth()>=481) {
            yieldbot.pub('be77');//desktop
            yieldbot.defineSlot('LB');
            yieldbot.defineSlot('MR', {sizes: [
                [300, 250],
                [300, 600]
            ]});
            yieldbot.defineSlot('MR_2', {sizes: [
                [300, 250],
                [300, 600]
            ]});
          } else {
            yieldbot.pub('061f');//mobile
            yieldbot.defineSlot('MLB');
            yieldbot.defineSlot('mobrec');
          }
          yieldbot.enableAsync();
          yieldbot.go();
        });
//--><!]]>
</script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script type="text/javascript" src="http://cdn.connatix.com/min/connatix.renderer.destination.min.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
  </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4136408 node-type-article domain-www-newrichmond-news-com context-news">

    <!-- Google Tag Manager -->
    <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L"
    height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":
    new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src=
    "//www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,"script","dataLayer","GTM-PF9F4L");</script>
    <!-- End Google Tag Manager -->

    <div id="skip-link">
      <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
    </div>
    <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <li class="last">
            <a href="/register" title="Register">Register</a>
          </li>
        </ul>
            <div id='out-of-page-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('out-of-page-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="New Richmond News"><img src="http://www.newrichmond-news.com/sites/all/themes/newrichmondnews_theme/logo.png" alt="New Richmond News" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">New Richmond News</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/news/government/4136408-watch-29th-district-state-assembly-candidate-forum" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div class="block-main-menu">
  <div class="block-inner clearfix">
    <ul class="menu">
      <li class='first leaf'><a href='/'>Home</a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/government/4136021-design-contract-seh-approved-nr-city-council'>Design contract with SEH approved by NR city council</a></li><li><a href='/news/government/4136408-watch-29th-district-state-assembly-candidate-forum'>WATCH: 29th District State Assembly candidate forum</a></li><li><a href='/news/government/4136409-watch-st-croix-county-district-attorney-candidate-forum'>WATCH: St. Croix County district attorney candidate forum</a></li><li><a href='/news/region/4136787-wisconsin-roundup-police-urge-packer-fans-beware-ticket-scams-feingold-johnson'>Wisconsin roundup: Police urge Packer fans to beware ticket scams; Feingold, Johnson squaring off Friday night; 11 more state news stories</a></li><li><a href='/news/politics/4136009-29th-assembly-da-candidate-forum-tonight-nr-civic-center'>29th Assembly, DA candidate forum tonight at NR Civic Center</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/tags/new-richmond" target="_self">New Richmond</a></li><li><a href="/tags/somerset" target="_self">Somerset</a></li><li><a href="/tags/roberts" target="_self">Roberts</a></li><li><a href="/tags/hammond" target="_self">Hammond</a></li><li><a href="/tags/star-prairie" target="_self">Star Prairie</a></li><li><a href="/tags/deer-park" target="_self">Deer Park</a></li><li><a href="/news/crime-and-courts" target="_self">crime and courts</a></li><li><a href="/news/government" target="_self">government</a></li><li><a href="/news/business" target="_self">business</a></li></ul></div></div></li>
<li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcats'><h2>Headlines</h2><ul><li><a href='/sports/high-school/4136876-new-richmond-football-hopes-head-playoffs-winning-note-friday'>New Richmond football hopes to head into playoffs on winning note Friday</a></li><li><a href='/sports/high-school/4136875-st-croix-central-football-needs-win-friday-get-state-playoffs'>St. Croix Central football needs win Friday to get into state playoffs</a></li><li><a href='/sports/high-school/4136874-somerset-football-team-finishes-season-friday-night'>Somerset football team finishes season Friday night</a></li><li><a href='/sports/high-school/4136667-new-richmond-girls-win-mbc-xc-title-wachter-swanson-are-individual'>New Richmond girls win MBC XC title; Wachter, Swanson are individual champions</a></li><li><a href='/sports/high-school/4136010-red-hot-new-richmond-soccer-team-ends-regular-season-thursday'>Red-hot New Richmond soccer team ends regular season Thursday</a></li></ul></div></div></li>
<li class='leaf'><a href="/news/education" target="_self">education</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcats'><h2>Headlines</h2><ul><li><a href='/news/education/4135174-somerset-new-richmond-celebrate-walk-school-day'>Somerset, New Richmond celebrate Walk to School Day</a></li><li><a href='/news/education/4135146-somerset-host-first-mbc-plc-ed-camp'>Somerset to host first MBC PLC Ed Camp</a></li><li><a href='/news/education/4135163-somerset-homecoming-2016'>Somerset Homecoming 2016</a></li><li><a href='/news/education/4135155-st-croix-central-homecoming-2016'>St. Croix Central Homecoming 2016</a></li><li><a href='/news/education/4130738-scc-high-school-students-month'>SCC High School students of the month</a></li></ul></div></div></li>
<li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/events/4135138-citizen-year-nominations-now-open'>Citizen of the Year nominations now open</a></li><li><a href='/life/events/4130741-tech-series-help-community-learn-more-about-their-devices'>Tech Series to help community learn more about their devices</a></li><li><a href='/life/4130731-somerset-public-library-hold-community-input-meeting'>Somerset Public Library to hold community input meeting</a></li><li><a href='/life/events/4129014-university-wisconsin-river-falls-will-host-its-inaugural-uw-river-falls-special'> University of Wisconsin-River Falls will host its inaugural UW-River Falls Special Olympics – Run with the Cops</a></li><li><a href='/life/health/4128213-two-free-health-classes-be-offered-westfields'>Two free health classes to be offered at Westfields</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/arts-and-entertainment" target="_self">arts and entertainment</a></li><li><a href="/life/food" target="_self">food</a></li><li><a href="/life/health" target="_self">health</a></li><li><a href="/life/religion" target="_self">religion</a></li><li><a href="/life/family" target="_self">family</a></li><li><a href="/life/events" target="_self">events</a></li></ul></div></div></li>
<li class='leaf'><a href="/notices" target="_self">notices</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcats'><h2>Headlines</h2><ul><li><a href='/legals/4133480-cedar-lake-alum-treatment-special-assessment-notice'>Cedar Lake Alum Treatment Special Assessment Notice</a></li><li><a href='/legals/4133260-city-new-richmond-fall-clean'>City of New Richmond - Fall Clean Up</a></li><li><a href='/legals/4133259-lien-sale-notice-star-prairie-storage-sat-oct-22-2016'>LIEN SALE NOTICE: Star Prairie Storage, Sat. Oct. 22, 2016</a></li><li><a href='/legals/4133258-lien-sale-notice-new-richmond-storage-sat-oct-22-2016'>LIEN SALE NOTICE: New Richmond Storage, Sat. Oct. 22, 2016</a></li><li><a href='/legals/4133257-village-star-prairie-august-24-2016-special-board-meeting-minutes'>Village of Star Prairie - August 24, 2016 Special Board Meeting Minutes</a></li></ul></div></div></li>
<li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcats'><h2>Headlines</h2><ul><li><a href='/obituaries/4133552-morton-t'>Morton T. </a></li><li><a href='/obituaries/4133551-louis-d-germain-70'>Louis D. Germain, 70</a></li><li><a href='/obituaries/4131731-verna-l-paulsen-81'>Verna L. Paulsen, 81</a></li><li><a href='/obituaries/4131660-helen-tveten-83'>Helen Tveten, 83</a></li><li><a href='/obituaries/4131084-jim-carver-84'>Jim Carver, 84</a></li></ul></div></div></li>
<li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/columns/4098162-todays-political-scene-filled-snake-oil-salesmen'>Today’s political scene filled with snake oil salesmen</a></li><li><a href='/opinion/letters/4098159-letters-editor-aug-18-2016'>Letters to the Editor: Aug. 18, 2016</a></li><li><a href='/opinion/editorials/4098161-our-view-both-presidential-candidates-ducking-press'>Our View: Both presidential candidates ducking the press</a></li><li><a href='/opinion/columns/4093545-fine-line-novembers-election-important'>A fine line: November&#039;s election is important</a></li><li><a href='/opinion/editorials/4093540-primary-over-election-gets-rolling'>Primary is over, election gets rolling</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/letters" target="_self">letters</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li></ul></div></div></li>
<li class='leaf no-doormat'><a href="/basic-page/3729456-magazine-rack" target="_self">Magazine Rack</a></li>
<li class='leaf no-doormat'><a href="https://en.calameo.com/read/00073526136127b70bf45" target="_self">Real Estate Showcase</a></li>
    </ul>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                                            <ul class="action-links"></ul>      <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="News "> <meta itemprop='dateline' content="New Richmond,Wisconsin 54017"> <meta itemprop='articleBody' content="&lt;p&gt;The New Richmond VFW Post 10818 Auxiliary hosted a candidate forum at the civic center in New Richmond Thursday, Oct. 13.&lt;/p&gt;&lt;p&gt;The live-streamed event that features the debate between Republican Rob Stafsholt and Democrat Scottie Ard, the two candidates vying for the 29th Assembly District seat, is included above.&lt;/p&gt;&lt;p&gt;About 80 were in attendance for the live debate. &lt;/p&gt;&lt;p&gt;New Richmond News reporter Tom Lindfors served as the moderator for this special forum.&lt;/p&gt;&lt;p&gt;In addition to the debate between Stafsholt and Ard, the Auxiliary also hosted a debate between Republican Michael Nieskes and Democrat Sarah Yacoub, both vying for the St. Croix County district attorney's seat. &lt;/p&gt;&lt;p&gt;That debate is available for viewing here. &lt;/p&gt;&lt;p&gt;The Fall General Election will be held Tuesday, Nov. 8. Polls will be open from 7 a.m. to 8 p.m. Voters will need to bring a valid ID card, either a driver's license or ID card issued through the DMV, in order to cast a ballot.&lt;/p&gt;&lt;p&gt;Early voting through an absentee ballot is also open through Nov. 4.&lt;/p&gt;&lt;p&gt;For more information about early voting, contact your village, town or city clerk.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="WATCH: 29th District State Assembly candidate forum"> <meta itemprop='author' content="Raymond Rivard"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.newrichmond-news.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2016-10-14T12:32:52"> <meta itemprop='dateModified' content="2016-10-14T12:32:52"> <link itemprop='mainEntityOfPage' content="node/4136408"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.newrichmond-news.com/sites/default/files/styles/square_300/public/field/image/IMG_9817.JPG?itok=kbP5S5dn"> <meta itemprop="width" content="4752"> <meta itemprop="height" content="3168"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Raymond Rivard"> </div> <div itemscope itemtype='http://schema.org/Person'> <meta itemprop='affiliation' content="New Richmond News"</span> <meta itemprop="name" content="Raymond Rivard"> <meta itemprop="homeLocation" content="New Richmond"> <div itemprop='contactPoint' itemscope itemtype='http://schema.org/ContactPoint'> <meta itemprop='faxNumber' content="715-246-7117"> <meta itemprop='contactType' content="customer support"> <meta itemprop='url' content="http://www.newrichmond-news.com"> <meta itemprop='telephone' content="(715) 243-7767 x241"> <meta itemprop='email' content="rrivard@rivertowns.net"> </div> <meta itemprop='url' content="http://www.newrichmond-news.com"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="WATCH: 29th District State Assembly candidate forum "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="New Richmond"> <meta itemprop='addressRegion' content="Wisconsin"> <meta itemprop='streetAddress' content="127 South Knowles Avenue"> <meta itemprop='postalCode' content="54017"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        });
        </script>
        </div><h1 class='node-title'>WATCH: 29th District State Assembly candidate forum</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/raymond-rivard'>Raymond Rivard</a></span>
  <span class='node-byline-time'> Today  at 12:32 p.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large article-slider'><button class='next'><img src='/sites/all/themes/fcc_basetheme/images/arrow-next.png'></button><button class='prev'><img src='/sites/all/themes/fcc_basetheme/images/arrow-back.png'></button><div class='individual-slide individual-slide-1' style='position: relative;'>    <!-- Open Graph -->
    <meta property="og:video" content="http://content.jwplatform.com/videos/AaLpJxhc.mp4" />
    <meta property="og:video:secure_url" content="https://content.jwplatform.com/videos/AaLpJxhc.mp4" />
    <meta property="og:video:type" content="video/jwplayer"/>
    <meta property="og:video:release_date" content=""/>
    <meta property="og:video:tag" content=""/>
    <meta property="og:video:duration" content="2272"/>
<span id="jwplayer-video-0">
            <!-- Schema.org -->
        <meta itemprop="name" content="29th District State Assembly candidate forum.mp4" />
        <meta itemprop="description" content="" />
        <meta itemprop="thumbnailUrl" content="https://assets-jpcust.jwpsrv.com/thumbs/AaLpJxhc-320.jpg" />
        <meta itemprop="contentUrl" content="https://content.jwplatform.com/videos/AaLpJxhc.mp4" />
        <meta itemprop="uploadDate" content="1969-12-31 18:00:00"/>
        <script type="text/javascript">
        var playerInstance = jwplayer("jwplayer-video-0");
            playerInstance.setup({"playlist":"\/\/content.jwplatform.com\/feeds\/AaLpJxhc.json","mediaid":"AaLpJxhc","width":"100%","hlshtml":true,"androidhls":true,"aspectratio":"16:9","ga":{},"autostart":"true","advertising":{"client":"googima","schedule":{"adbreak1":{"offset":"pre","tag":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?iu=\/7021\/fcc.forum\/newrichmond-news&sz=640x480&cust_params=kw%3DElection+2016%2Cnew+richmond%2Cwisconsin%2Cscottie+ard%2CRob+Stafsholt%2C29th+district%2CNews%2Cgovernment&ad_rule=0&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=%5BREFERRER_URL%5D&correlator=%5BTIMESTAMP%5D"},"adbreak2":{"offset":"post","tag":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?iu=\/7021\/fcc.forum\/newrichmond-news&sz=640x480&cust_params=kw%3DElection+2016%2Cnew+richmond%2Cwisconsin%2Cscottie+ard%2CRob+Stafsholt%2C29th+district%2CNews%2Cgovernment&ad_rule=0&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=%5BREFERRER_URL%5D&correlator=%5BTIMESTAMP%5D"}}}});
            // Ad Error
            playerInstance.on('adError', function (event) {
                console.log('JWPlayer: Ad Error');
                console.log(event);
            });
    </script>
</span>
<style>
    .page-node div.article-slider div.individual-slide-1 {
        display: inline-block;
    }
    div.individual-slide { margin-top: -58px; }
</style>
<span class='slide-number'>1 / 2</span></div><div class='individual-slide individual-slide-2' style='position: relative;'><img class='node-image large' src='http://www.newrichmond-news.com/sites/default/files/styles/16x9_620/public/field/image/IMG_9817.JPG?itok=ahfIx7rB' data-featherlight='http://www.newrichmond-news.com/sites/default/files/styles/full_1000/public/field/image/IMG_9817.JPG?itok=60nNX4pi'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Rob Stafsholt and Scottie Ard at Thursday night&#039;s debate in New Richmond. (Raymond T. Rivard photograph)</span><span class='slide-number'>2 / 2</span></div></div><div class='node-body'><p>The New Richmond VFW Post 10818 Auxiliary hosted a candidate forum at the civic center in New Richmond Thursday, Oct. 13.</p></div><div class='node-ad node-ad-desktop'><div id='article-sidebar-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('article-sidebar-ad');
          });
        });
        </script>
        </div></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        });
        </script>
        </div><div class='p402_premium'><div class='node-body'><p>The live-streamed event that features the debate between Republican Rob Stafsholt and Democrat Scottie Ard, the two candidates vying for the 29th Assembly District seat, is included above.</p><p>About 80 were in attendance for the live debate. </p><p>New Richmond News reporter Tom Lindfors served as the moderator for this special forum.</p><p>In addition to the debate between Stafsholt and Ard, the Auxiliary also hosted a debate between Republican Michael Nieskes and Democrat Sarah Yacoub, both vying for the St. Croix County district attorney's seat. </p><p><img alt="Rob Stafsholt and Scottie Ard at Thursday night&#039;s debate in New Richmond. (Raymond T. Rivard photograph" class="media-image" height="320" title="" width="480" typeof="Image" src="http://www.riverfallsjournal.com/sites/default/files/styles/large/public/IMG_9817.JPG?itok=ravWj9m_" />That debate is<a href="http://www.newrichmond-news.com/news/government/4136409-watch-st-croix-county-district-attorney-candidate-forum" target="_blank"> </a><a href="http://www.newrichmond-news.com/news/government/4136409-watch-st-croix-county-district-attorney-candidate-forum" target="_blank"><strong>available for viewing here</strong></a>. </p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>The Fall General Election will be held Tuesday, Nov. 8. Polls will be open from 7 a.m. to 8 p.m. Voters will need to bring a valid ID card, either a driver's license or ID card issued through the DMV, in order to cast a ballot.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>Early voting through an absentee ballot is also open through Nov. 4.</p><p>For more information about early voting, contact your village, town or city clerk.</p></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.newrichmond-news.com/taxonomy/term/1'>News</a><a class='topic category' href='http://www.newrichmond-news.com/taxonomy/term/15121'>government</a><a class='topic tag' href='http://www.newrichmond-news.com/taxonomy/term/74102'>Election 2016</a><a class='topic tag' href='http://www.newrichmond-news.com/taxonomy/term/30287'>new richmond</a><a class='topic tag' href='http://www.newrichmond-news.com/taxonomy/term/121643'>wisconsin</a><a class='topic tag' href='http://www.newrichmond-news.com/taxonomy/term/340800'>scottie ard</a><a class='topic tag' href='http://www.newrichmond-news.com/taxonomy/term/356264'>Rob Stafsholt</a><a class='topic tag' href='http://www.newrichmond-news.com/taxonomy/term/356265'>29th district</a></div><div class='node-author-block clearfix'><a class='node-author-name' href='/users/raymond-rivard'>Raymond Rivard</a><img class='node-author-pic' src='http://www.newrichmond-news.com/sites/default/files/styles/vert_175/public/pictures/picture-335805-1445539486.jpg?itok=IUBo_KUC'><div class='node-author-bio'><p>Raymond T. Rivard joined the New Richmond News as editor in August 2015. With 26 years of experience in journalism, Rivard spent 10 years with THE-BEE in Phillips and the past 15 years with The Lakeland Times in Minocqua.</p></div><div class='node-author-email'>
        <a href='/user/335805/contact'>
          <span itemprop='email'>rrivard@rivertowns.net</span>
        </a>
        </div><div class='node-author-number'>(715) 243-7767 x241</div><div class='author-social-wrapper'><div class='fb-follow' data-href='https://www.facebook.com/newrichmondnews/?ref=hl' data-colorscheme='light' data-layout='standard' data-show-faces='false'></div></div></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',11);
  ga('send', 'event', 'article', 'paragraphs', '11');
  ga('send', 'event', 'article', 'length', 'characters',1742);
  ga('send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',6046);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',11);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '11');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',1742);
  ga('combinedSites.send', 'event', 'article', 'age', 'Less than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',6046);
</script>    </div>
  </div>
</div>              </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/government/4136021-design-contract-seh-approved-nr-city-council"><span class="number">1. </span>Design contract with SEH approved by NR city council</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/news/crime-and-courts/4134950-update-new-richmond-man-being-evaluated-after-five-hour-stand-ends"><span class="number">2. </span>UPDATE: New Richmond man being evaluated after five-hour stand-off ends peacefully</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/government/4136409-watch-st-croix-county-district-attorney-candidate-forum"><span class="number">3. </span>WATCH: St. Croix County district attorney candidate forum</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/region/4135987-meeting-tonight-6-pm-information-about-corn-lawsuit-be-provided-deer-park"><span class="number">4. </span>Meeting tonight 6 p.m.: Information about corn lawsuit to be provided in Deer Park</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4136667-new-richmond-girls-win-mbc-xc-title-wachter-swanson-are-individual"><span class="number">5. </span>New Richmond girls win MBC XC title; Wachter, Swanson are individual champions</a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4136876-new-richmond-football-hopes-head-playoffs-winning-note-friday">New Richmond football hopes to head into playoffs on winning note Friday<span class='latest-date'>3 min ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4136875-st-croix-central-football-needs-win-friday-get-state-playoffs">St. Croix Central football needs win Friday to get into state playoffs<span class='latest-date'>5 min ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/high-school/4136874-somerset-football-team-finishes-season-friday-night">Somerset football team finishes season Friday night<span class='latest-date'>8 min ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/government/4136021-design-contract-seh-approved-nr-city-council">Design contract with SEH approved by NR city council<span class='latest-date'>1 hour ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/government/4136408-watch-29th-district-state-assembly-candidate-forum">WATCH: 29th District State Assembly candidate forum<span class='latest-date'>1 hour ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-wishabi-article block-fcc-advertising-wishabi-article odd block-without-title" id="block-fcc-advertising-wishabi-article">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Wishabi Circular widget on Article -->
          <div id='circularhub_module_6251' class='nocontent'></div>
          <script src='http://api.flyertown.ca/6251/2abb546c0a8af6a5/circularhub_module.js'></script>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><section class="block block-views block-classified-featured-block block-views-classified-featured-block odd" id="block-views-classified-featured-block">
  <div class="block-inner clearfix">
              <h2 class="block-title">Top Ads</h2>
            
    <div class="content clearfix">
      <div class="view view-classified-featured view-id-classified_featured view-display-id-block view-dom-id-747e71188905c0652831f1a1525ed79e">
    
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2393272">
      COMMERCIAL SPACE available in new building with nice convenient location!  <br>Commercial Park off Hwy C., Somerset, WI.  <br> <br>    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-2 views-row-even top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2385212">
      LADIES SPRING PIT STOP  <br>LOCAL CRAFT & VENDOR EVENT  <br> <br>Hastings KC Hall  <br>3075 Vermillion St., Hastings, MN    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-3 views-row-odd top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2393295">
      Tim Alms Photography <br>Great Gift Idea for home or office!  <br>Many photos and sizes to choose from, framed or unframed.  <br>    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-4 views-row-even top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2393309">
      Brand New TYR Swim Jammers, never been used! Size 24 (waist), too small for my son. Perfect for any boy on a swim team.  (New: $35)   Asking: $25.    </a>
    </span>
  </p>
  </div>
  </div>
  <div class="views-row views-row-5 views-row-odd views-row-last top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2393285">
      WE BUY AND TOW Unwanted and Wrecked Vehicles.   <br>MN Licensed Dealer.   <br>Call for Quote: 651-322-1800   <br>www.upullrparts.com    </a>
    </span>
  </p>
  </div>
  </div>
    </div>
              <span class="class-11px"><a href="/classifieds/featured">View all top ads &raquo;</a></span>
</div>    </div>
  </div>
</section><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-homeshq-widget block-boxes-homeshq-widget odd block-without-title" id="block-boxes-homeshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-homeshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="homes_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget even block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='https://newspaper.forumcomm.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=RNR' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/newrichmond-news" title="">Subscribe to the Paper</a></li>      <li><a href="http://www.newspaperprints.com" title="">Buy Newspaper Prints</a></li>
      <li><a href="http://www.rivertownmultimedia.com">Advertise with us</a></li>    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="http://forumcomm.desk.com/" title="">Get Website Help</a></li>
      <li><a href="http://www.jobshq.com/employers/page/profile/employer/34/" title="">Work With Us</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.twitter.com/newrichmondnews" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/newrichmondnews" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li><li><a href="https://plus.google.com/102646955521009741833/" title="Find us on Google+" rel="publisher"><img alt="Find us on Google+" src="/sites/all/themes/fcc_basetheme/images/icons/google-social.png" /> Google+</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; New Richmond News</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; New Richmond News</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">127 South Knowles Avenue</div>
      <span class="locality">New Richmond</span>, 
      <span class="region">Wisconsin</span> 
      <span class="postal-code">54017</span>
    </div>

    Call us at <div class="tel">715-246-6881</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php"><!-- randomness --></a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/modules/custom/fcc_advertising/adblock/min/adblock.min.js?of02v8"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=newrichmond-news.com&tags=News, government,Election 2016, new richmond, wisconsin, scottie ard, Rob Stafsholt, 29th district',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="http://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?of02v8"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?of02v8"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_T39c94Z0dgQrqwOtOS7BQw2wmWjHrXfnDT51JKKVt84.js"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?of02v8"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?of02v8"></script>
<script type="text/javascript" src="http://www.newrichmond-news.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
        ybotq.push(function() {
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        });
        </script>
        </div>  </body>
</html>